这里是 LitePress 社区旧贴存档,您可以在此留言或提交新的回应和信息。

·

这里是 LitePress 社区旧贴存档,您可以在此留言或提交新的回应和信息。
文章投稿 131 篇
参与 1035 次讨论和 239 条回复之前也是用的这个主题测试没问题的。没更新主题没安装任何东西突然这样了
目前已经完成了翻译过程挪到前端的目标,但目前还不支持术语表
d 参数是指定在未找到头像的情况下所调用的默认头像类型。API 文档上有关于这一块的解释
问题已解决:‘?&d=identicon’这个参数的作用好像是获取随机头像,保持不变;把“ https://www.gravatar.com/ ”换成“ https://cravatar.cn/ ”即可。
各位:一句话,“Gravatar 头像地址”那段代码中,API文档教程里生成的hash值不用填,是吗?
此账号数据已清除
一点编程基础没有的话我很难给你解释清楚欸。建议找个懂开发的定制一下这个功能
‘?&d=identicon’
这部分保持不变,还是填生成的邮箱md5?
api文档里生成的hash值填不填?我填了md5生成的邮箱hash值,结果又乱了,还是不显示,头像链接成了这样:
https://cravatar.cn/avatar4f0efac4307dd52cee089ed67695355b?&d=4f0efac4307dd52cee089ed6769355b
一、我们没主动做任何限制,所以国外也应该是可以用的,并且 CDN 也有国外节点
二、去掉两侧空格是因为有的人敲邮箱可能会在末尾多敲一个空格,所以哈希前得先去除
三、把域名替换成 cravatar.cn 即可
wp-config.php 里面的 WP_Debug 宏设置为 true,然后刷新页面把报错信息贴上来
前边发的是前段登录的提示,
这个是登陆后台的提示:
此站点遇到了致命错误,请查看您站点管理员电子邮箱中收到的邮件来获得指引。
邮箱里也没有收到邮件
就是刚打开后台,在后台准备上传插件,还没开始就挂了
出现致命错误之前,你操作了什么?
注插件还未开始上传就整个站变成这样了
我们之前是支持直接删除用户数据的,但是运行过程中发现了一些问题:
因为我们的会员系统是基于“终极会员”插件制作的,此插件在处理用户注销请求时会直接硬删除用户的会员信息以及关联的所有信息,这导致我们的系统因为匹配不到数据到处报错以及论坛帖子关系错乱。
我们知道用户的数据属于用户,用户应该有权力随时要求抹除数据,所以此功能只是暂时关闭,我们计划对其重构,改成软删除的模式,也就是在请求删除时保留用户 ID 及其他关联数据,但清除包括邮箱、密码、手机号在内的所有涉及因素的数据。
另外,关于用户所发的帖子。按道理讲,用户发的帖子其版权也应该归用户所有,但现在我们面临的情况是用户所发的绝大部分帖子都是问题咨询类帖子,这些帖子单就内容本身老实说我个人觉得是没有价值的,同时我们管理员包括其他志愿者针对该问题给出的解决方案又与此问题相关联。如果允许用户直接删除帖子,则会影响到其他人创作的内容(所谓的影响主要是使话题缺失上下文,或干脆整个话题无法索引)。我记忆最深的是我之前有回复过一个用户关于 WordPress Rest API 超时的问题,我从问题机理开始写了上千字来解答他的疑惑,最后全被删掉,老实说心里很不是滋味。我们虽然不是完全无私的在做这些事情,但也并没有对用户收费,作为用户方在问题获得解答后删除所有数据我觉得不太妥当,因为这其中包含了其他人的劳动成果。当然,如果是用户的原创文章希望删除的话后续会留下渠道来供其申请。
之前因为一直没人提用户注销这块的问题,所以重构工作一直在拖延。本次你提了后我们尽可能在明天晚上之前处理好重构工作然后给你回复。如果你有其他想法或者意见也可以直接回复这个帖子,我们会随时关注。
okk!非常感谢
F12看下 CDN 链接成功没 JSdelivr 经常被墙
仓库容量达上限了,没法用jsdelivr获取,你用开发者工具看一下加载字体的链接正不正常就知道了
宝塔使用自己的btpython,因此你的命令不会对其生效。
我去试试
你这个问题目测是 pip 无法安装 Python 扩展导致的,尝试执行:
pip3 install gevent
如果仍然无法安装的话请更换一下 pip 源,然后再重新执行宝塔的安装脚本。
更换 pip 源教程:
https://blog.csdn.net/weixin_41714373/article/details/119911508
文本文档发不了我刚才把整个日志都写上去了~
有安装失败的原因吗?
这个项目目前还处于开发阶段,本土版本和原本的主要区别在于优化了各种外部网络接口的速度以及提供更好的汉化支持,同时会使应用市场支持闭源和付费的应用
我想找份wp跟我们lite的对比,使用lite比用wp好在哪里
好吧,谢谢
有推荐吗?
你这样搞的话你网站开一个页面可能要好几秒。这个不具有任何可行性的,而且也不会减少数据库压力。
比较可行的方案是各种动态缓存和页面静态化。
没听过数据库套CDN,如果负载高的话,用静态缓存插件试试
加油加油
你说的这个应该是类似于企业里用一台做网关服务器提供对外访问,然后其他服务器在内部运行计算服务吧。他们这种比较简单的实现就是用 Nginx 的反向代理来做,包括 wordpress.com 也是这样干的。
发表回复